PHP 5.3, 5.4, 5.5, 5.6 support on Debian GNU/Linux 9 “Stretch”

Holbihost continues to provide support for PHP versions 5.3, 5.4, 5.5, 5.6 on the newest Linux based Operating Systems, like Debian GNU/Linux 9 “Stretch”.

Debian 9 is shipped with latest OpenSSL 1.1 out of the box. But it is known fact that old PHP versions 5.3, 5.4, 5.5, and still supported PHP 5.6 version, are compatible with OpenSSL 1.0 and not compatible with OpenSSL 1.1.

Also PHP core team confirmed that PHP 5.6 (supported until January 1st, 2019) will never compile against OpenSSL 1.1.

Therefore it is not possible to build and use PHP versions 5.3, 5.4, 5.5, 5.6 on Debian 9 with default OpenSSL 1.1.

Considering that many our existent and new clients still require PHP 5 support for their projects, but at the same time require modern, secure and long-term supported Operating System, Holbihost implemented PHP 5.3, 5.4, 5.5, 5.6 support on Debian GNU/Linux 9 “Stretch”.

Important notice: PHP 5 versions will be fully supported by Holbihost on Debian 9 until June, 2022.

 

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.